Home Articles Downloads Forum Products Services Seminar Contact
Previous Thread
Next Thread
Print Thread
Rate Thread
Fresenius Agilia Infusion Pumps #74865 04/02/20 1:34 AM
Joined: Jan 2020
Posts: 8
williamss Offline OP
Newbie
OP Offline
Newbie
Joined: Jan 2020
Posts: 8
Does anyone have experience with these infusion pumps - good or bad. Especially the large volume IV pump.

Re: Fresenius Agilia Infusion Pumps [Re: williamss] #74866 04/02/20 1:47 AM
Joined: Jun 2009
Posts: 771
DaveC in Oz Offline
Philosopher
Offline
Philosopher
Joined: Jun 2009
Posts: 771
Yes, they are used throughout the state public hospital system here in New South Wales. I think they are very good, we have a few issues but the support here is top rate. They have up until recently provided 5 years warranty but the new state contract offers 10 years!
There are a couple of "known issues" one that is a cable working loose (Motor rotation error) which takes about 5 minutes to fix so we don't bother sending them in for repair and we are seeing some power supply issues now ( 5 years in use) but you just stick the pump in a box, email the repair form in to the company and they take it from there. Little effort or time involved from our part. The company also come on site and do the annual testing so all in all, we luv'em grin

Dave


Thoughts and information provided on this forum are mine and mine alone and do not necessarily reflect the policy of NSW Health. They may also be complete bollocks!!
Re: Fresenius Agilia Infusion Pumps [Re: williamss] #74867 04/02/20 8:49 AM
Joined: Jul 2016
Posts: 6
UmeshKirant Offline
Newbie
Offline
Newbie
Joined: Jul 2016
Posts: 6
The infusion pumps are good enough but there could be some known issues. One most frequently faced issue is the "Door Open" alarm even when the door is closed. But resetting the connection usually does the job and takes around 15-20 minutes.

One time the vendors sent in pumps without the microdose calculation and we had to return and exchange all of them.

For the price, it's good and reliable.


Umesh
Re: Fresenius Agilia Infusion Pumps [Re: williamss] #74924 18/02/20 1:56 AM
Joined: Jan 2020
Posts: 8
williamss Offline OP
Newbie
OP Offline
Newbie
Joined: Jan 2020
Posts: 8
Umesh, can you explain resetting the connection - do you mean to the network or just rebooting the device.

Re: Fresenius Agilia Infusion Pumps [Re: williamss] #74926 18/02/20 11:00 AM
Joined: Feb 2004
Posts: 13,942
Geoff Hannis Online Content
Super Hero
Online Content
Super Hero
Joined: Feb 2004
Posts: 13,942

... or maybe opening the unit and re-seating the sensor connector? think


If you don't inspect ... don't expect.

Moderated by  DaveC in Oz, KM, RoJo 

Who's Online Now
2 registered members (OxyKate, Geoff Hannis), 693 guests, and 29 spiders.
Key: Admin, Global Mod, Mod
Newest Members
SailFaster99, Eyhab, Pablo Patriota, kdmus2020, Mohamed Alsapagh
9562 Registered Users
Forum Statistics
Forums25
Topics10,499
Posts71,029
Members9,562
Most Online5,980
Jan 29th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.2