Home Articles Downloads Forum Products Services EBME Expo Contact
Previous Thread
Next Thread
Print Thread
Rate Thread
Joined: Nov 2022
Posts: 2
Joost Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2022
Posts: 2
Hi all!

New to the forum, it's a pleasure!

I'm working as a medical doctor in a rural district hospital in Shirati, which was provided with a Xitec Xiscan last year. It was working fine initially, but after not being in use for 3 months, it suddenly wouldn't function anymore. After connecting the console with the power supply, the console seems to be turning on fine. The C-arm power is also comes on easily, when the key is turned. However, the display on the C-arm itself won't turn on. We have tested the cable for connectivity and found it is working fine. It seems that no power reaches the cable from the console, to go to the C-arm. I've added photos of the machine, hoping it might help.

The original USA supplier stopped activity around 2006. Another supplier I've contacted doesn't respond.

Any advice on what might be the problem and if there is any chance of salvaging this piece of equipment?

Kind regards!

Joost Binnerts

Attached Images
20221110_135955.jpg (44.76 KB, 20 downloads)
20221110_135939.jpg (59.57 KB, 20 downloads)
20221110_142428.jpg (65.23 KB, 20 downloads)
20221110_142437.jpg (53.2 KB, 20 downloads)
Joined: Feb 2004
Posts: 14,676
Likes: 63
Super Hero
Offline
Super Hero
Joined: Feb 2004
Posts: 14,676
Likes: 63
Welcome to the forum, Joost.

No power to the C-Arm ... could be something simple (like a poor connection, fuse, etc.); but it's difficult to say without actually being there.

Don't you have any electricians (or even "handy men") around? Or, better yet, are you in touch with Frank Weithöner?

Meanwhile, it looks like the panel shown in the first photo has been "visited". What's underneath (inside) it, I wonder?


If you don't inspect ... don't expect.
Joined: Nov 2022
Posts: 2
Joost Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2022
Posts: 2
Hi Geoff!

Thank you for your reply! We have a handyman for sure, who's tested the cable linking the console to the C-arm itself, which showed a functional cable.

I arrived at this forum due to Franks website, which specifically requests visitors not to ask him for technical advice wink

The damaged panel is a sharp observation. I'll check!

Joost

Joined: Feb 2004
Posts: 14,676
Likes: 63
Super Hero
Offline
Super Hero
Joined: Feb 2004
Posts: 14,676
Likes: 63
From your earlier post I gathered that the display panel on the C-arm is not lighting up. Did I get that right?

I mentioned Frank as I believe he used to travel about doing Good Deeds in and around your location. Perhaps that's no longer the case.

But at least you've got a nice view of Lake Victoria.


If you don't inspect ... don't expect.

Moderated by  DaveC in Oz, RoJo 

Link Copied to Clipboard
Who's Online Now
0 members (), 418 guests, and 292 robots.
Key: Admin, Global Mod, Mod
Newest Members
diodoled, Al BMET, Eng_VPG, Graham Oliver, Jawad
10,188 Registered Users
Forum Statistics
Forums25
Topics11,073
Posts73,785
Members10,188
Most Online5,980
Jan 29th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.5