Home Articles Downloads Forum Products Services Seminar Contact
Previous Thread
Next Thread
Print Thread
Rate Thread
Page 1 of 2 1 2
Joined: Dec 2016
Posts: 13
Techice Offline OP
Novice
OP Offline
Novice
Joined: Dec 2016
Posts: 13
Dear All,

A Braun perfusor fm (MFC) syringe pump, a fault is displayed as a SYRINGE ALARM after a few seconds that was switched ON. Anyone can help me on this issue please?


Best Regards,
Techice.

Joined: Jul 2002
Posts: 2,020
Hero
Offline
Hero
Joined: Jul 2002
Posts: 2,020
Frank has the service manual, that might help you.
Robert


My spelling is not bad. I am typing this on a Medigenic keyboard and I blame that for all my typos.
Joined: Dec 2016
Posts: 13
Techice Offline OP
Novice
OP Offline
Novice
Joined: Dec 2016
Posts: 13
Hi ROJo,


Thanks for your reply.Alreday have the service manual.

Have this manual,Please see the below link:

http://www.frankshospitalworkshop.com/eq...vice_manual.pdf

But regards this error SYRINGE ALARM,I cant find any explanation.

Best Regards,
Techice

Joined: Feb 2004
Posts: 14,257
Likes: 20
Super Hero
Online Content
Super Hero
Joined: Feb 2004
Posts: 14,257
Likes: 20

It gets an honourable mention in passing on page 2-11. smile

To be honest, compared with some (many) "modern" manuals I have seen, that one appears quite comprehensive.

Joined: Sep 2006
Posts: 745
Philosopher
Offline
Philosopher
Joined: Sep 2006
Posts: 745
Hello

Frank also does the Operators Manual; try page 12.
http://www.frankshospitalworkshop.com/eq...er%20manual.pdf

Lee


Don't forget "we've never had it so good".
Joined: Dec 2016
Posts: 13
Techice Offline OP
Novice
OP Offline
Novice
Joined: Dec 2016
Posts: 13
Hi Lee,

Thanks for your reply,

There is no information on page 12,(A fault is displayed as a SYRINGE ALARM)I would be much appreciated if someone tell me how a drive unit(Syringe Plunger)alignment can be done.

I am 100% sure that the fault comes from the drive unit(Syringe Plunger).

Techice

Joined: Dec 2016
Posts: 13
Techice Offline OP
Novice
OP Offline
Novice
Joined: Dec 2016
Posts: 13
Hi Geoff,

Thanks for your reply.


Sorry,but I read all the pages on service manual and user manual but no information found regards SYRINGE ALARM error.

I am 100% sure that the problem comes from the drive unit(Syringe Plunger)do you know if there is any alignments what can I do?

Techice

Joined: Sep 2006
Posts: 745
Philosopher
Offline
Philosopher
Joined: Sep 2006
Posts: 745
Hello Techice

Page 12 says under Operating alarms

"Syringe alarm
Fault on syringe replacement? Manipulation of
syringe holder during infusion?"

So presumably you need to be looking at what ever systems monitor that a syringe is in place and possibly the sensor for detecting the size of the syringe.

Lee


Don't forget "we've never had it so good".
Joined: Dec 2016
Posts: 13
Techice Offline OP
Novice
OP Offline
Novice
Joined: Dec 2016
Posts: 13
Hello Lee,

Thanks for your reply.

Yes, I see this notice as well. But not the syringe holder for sure. I replaced with another drive unit(Syringe plunger)and the syringe pump works well.

In fact I perform a syringe holder(Syringe clamp)calibration to make sure that works good.

I think something in the drive unit(Syringe plunger)like a calibration or alignment.

Best Regards,
Techice

Joined: Sep 2006
Posts: 745
Philosopher
Offline
Philosopher
Joined: Sep 2006
Posts: 745
Hello Techie

On the Perfusor Space version there is a sensor in the drive head that detects contact with the syringe plunger and the position of the claws is also monitored.

If the FM is the same; then your fault could have been either of those.

Lee


Don't forget "we've never had it so good".
Page 1 of 2 1 2

Moderated by  DaveC in Oz, RoJo 

Link Copied to Clipboard
Who's Online Now
5 members (Dustcap, Lindopski, Huw, Malcolm, ipetev), 139 guests, and 26 robots.
Key: Admin, Global Mod, Mod
Newest Members
Natali, Patrick Healy, Lazrdo, tdavis1984, tkinno4660
9,789 Registered Users
Forum Statistics
Forums25
Topics10,695
Posts72,183
Members9,789
Most Online5,980
Jan 29th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.5