I (still) don't have a 64-bit machine myself, but other users have reported running TM OK on 64-bit laptops.

You may (or may not) need to change the Compatibility Mode setting under the Compatibility tab on the Properties form for the desktop icon you are using.

Recent versions of TM were compiled under 32-bit Win 7. smile


If you don't inspect ... don't expect.